Back to overview
Downtime
Bot Downtime
Apr 6, 2026 at 9:58am UTC
Affected services
Ro Co Utilities
Created
Apr 6, 2026 at 9:58am UTC
Our Discord bot is down.
Affected services
Created
Apr 6, 2026 at 9:58am UTC
Our Discord bot is down.
Affected services