Back to overview
Games Unavailable
Dec 19, 2025 at 8:47am UTC
Affected services
Main Game
Training Centre
Hiring Centre
Ranking Centre
Resolved
Dec 19, 2025 at 8:47am UTC
All games experienced downtime.
Affected services
Resolved
Dec 19, 2025 at 8:47am UTC
All games experienced downtime.
Affected services