Back to overview
Application Centre
Jun 7, 2025 at 7:46pm UTC
Resolved
Aug 27, 2025 at 7:18am UTC
Application Downtime
More on Discord Server
Affected services
Created
Jun 7, 2025 at 7:46pm UTC
We are upgrading our Application Centre, making the Ro Co Application Bot update your rank, instead of my account doing so. This may break the Application Centre.
Affected services